Power outage in S1 impacting a small number of sites in S1 & S3
Incident Report for Pine Media Ltd
Resolved
NPG have resolved their incident
Posted Aug 03, 2023 - 12:35 BST
Investigating
Norther Powergrid are working on restoring service, the latest estimate is currently 13:00. Their incident ID is INCD-423842-A
Posted Aug 03, 2023 - 09:26 BST
This incident affected: Postcode Areas (S1, S3).