Northern Powergrid Incident affecting GIG & AIR customers in S33
Incident Report for Pine Media Ltd
Resolved
NPG have restored electricity to all properties, if you are still facing issues connecting please get in touch.
Posted Oct 21, 2023 - 13:57 BST
Update
Northern Powergrid update: INCD-447526-A Premises Affected:510
Restoration Estimate:1:00 PM - 21 Oct'23
Posted Oct 21, 2023 - 12:04 BST
Investigating
We are currently investigating this issue.
Posted Oct 21, 2023 - 12:03 BST
This incident affected: Postcode Areas (S33).