All Systems Operational
Core Operational
90 days ago
99.88 % uptime
Today
Postcode Areas Operational
90 days ago
99.55 % uptime
Today
S1 Operational
90 days ago
98.72 % uptime
Today
S2 Operational
90 days ago
96.28 % uptime
Today
S3 Operational
90 days ago
100.0 % uptime
Today
S6 Operational
90 days ago
99.94 % uptime
Today
S10 Operational
90 days ago
99.71 % uptime
Today
S11 Operational
90 days ago
100.0 % uptime
Today
S33 Operational
90 days ago
100.0 % uptime
Today
S35 Operational
90 days ago
100.0 % uptime
Today
S36 Operational
90 days ago
100.0 % uptime
Today
S80 Operational
90 days ago
100.0 % uptime
Today
NG17 Operational
90 days ago
100.0 % uptime
Today
TN14 Operational
90 days ago
100.0 % uptime
Today
Phone Services (VOIP) Operational
90 days ago
100.0 % uptime
Today
Residential Phone Services Operational
90 days ago
100.0 % uptime
Today
Business Phone Services Operational
90 days ago
100.0 % uptime
Today
Carrier / Transit Providers ? Operational
90 days ago
99.96 % uptime
Today
Cogent Operational
90 days ago
100.0 % uptime
Today
CityFibre Operational
90 days ago
100.0 % uptime
Today
Neos Operational
90 days ago
99.88 % uptime
Today
BT Wholesale Operational
90 days ago
100.0 % uptime
Today
Lumen Operational
90 days ago
99.96 % uptime
Today
GLO Sheffield City Region Operational
90 days ago
99.88 % uptime
Today
GLO Sheffield Centre ? Operational
90 days ago
99.76 % uptime
Today
GLO Sheffield South ? Operational
90 days ago
100.0 % uptime
Today
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Past Incidents
Mar 29, 2024

No incidents reported today.

Mar 28, 2024

No incidents reported.

Mar 27, 2024
Resolved - We met with the Openreach engineer who was able to resolve the issue with their equipment in their exchange with the assistance of our engineer. The faulty equipment was serviced which brough services back online at approximately 09:10AM. If you are still experiencing issues please contact our support team as this will be unrelated.
Mar 27, 11:01 GMT
Update - Openreach attended site and replaced the equipment but they were unfortunately unable to restore connectivity, after further diagnostics it appears that more equipment may have gone faulty. A follow up engineer visit has been scheduled by Openreach to attend site from 8AM, we will also be sending one of our engineers to meet with them to ensure a timely resolution is met.

We sincerely apologies for any inconvenience caused.

Mar 27, 04:00 GMT
Update - The equipment has been delivered and an Openreach engineer is enroute to collect and fit. Still no ETA on resolution from Openreach at this moment in time.
Mar 26, 22:12 GMT
Update - The Openreach engineer attended site earlier to clean and reseat the SFP on their equipment to try and resolve the issue that prompted the maintenance visit but in doing so the equipment failed and therefor needs to be replaced. A replacement has been ordered and we are currently awaiting a revised ETA from them now.

We apologise for the inconvenience caused and are continually chasing updates from Openreach. When we do have further correspondence we will provide an update here.

Mar 26, 21:25 GMT
Update - A very small portion of our GLO customers are currently experiencing an outage due to some emergency maintenance being carried out by Openreach. We estimate that this is currently impacting approximately 21 customers. Expected resolution time is 23:00 today but will keep you updated in the event this does change for any unforeseen reason.

We apologise for the inconvenience this may cause.

Mar 26, 16:40 GMT
Update - We are continuing to work on a fix for this issue.
Mar 26, 16:30 GMT
Identified - We are currently investigating an outage affecting a small portion of our GLO customers
Mar 26, 16:03 GMT
Mar 26, 2024
Mar 25, 2024

No incidents reported.

Mar 24, 2024

No incidents reported.

Mar 23, 2024

No incidents reported.

Mar 22, 2024

No incidents reported.

Mar 21, 2024

No incidents reported.

Mar 20, 2024

No incidents reported.

Mar 19, 2024

No incidents reported.

Mar 18, 2024

No incidents reported.

Mar 17, 2024

No incidents reported.

Mar 16, 2024

No incidents reported.

Mar 15, 2024

No incidents reported.