Power cut affecting S1
Incident Report for Pine Media Ltd
Resolved
Power and services have now been restored. If you are still experiencing issues, please get in touch with our support team on 0114 299 1699 or support@pinemedia.net
Posted May 26, 2020 - 08:20 BST
Investigating
We are aware of a power cut affecting some buildings across the City Centre. An engineer is on site trying to resolve.
Posted May 26, 2020 - 07:52 BST
This incident affected: Postcode Areas (S1, S3).