GLO Customers offline
Incident Report for Pine Media Ltd
Resolved
This incident has been resolved.
Posted Jan 20, 2023 - 10:01 GMT
Monitoring
We are seeing traffic levels returning to normal, please contact us if you are still facing issues.
Posted Jan 20, 2023 - 09:37 GMT
Update
There is an Openreach issue at the Sheffield exchange which is impacting all customers served from this exchange on our GLO service. Our own network remains unaffected.
Posted Jan 20, 2023 - 09:34 GMT
Investigating
We are aware of an issue affecting our GLO customers. Our teams are currently investigating.
Posted Jan 20, 2023 - 09:27 GMT
This incident affected: GLO Sheffield City Region (GLO Sheffield Centre).