Queens Tower - Some Services Offline
Incident Report for Pine Media Ltd
Resolved
This incident has been resolved.
Posted Apr 17, 2024 - 15:01 BST
Investigating
A select few services are offline due to weather damage at the site.

We have an engineer due to attend to identify the issue location for the building management.
Posted Apr 16, 2024 - 17:42 BST
This incident affected: Postcode Areas (S2).